Commit 7b2e5451 authored by Rene Hadler's avatar Rene Hadler

pve6-usb-automount: Switch to pyside2 for less dependencies

parent 4ccb649b
pve6-usb-automount (0.4-1) precise; urgency=low
pve6-usb-automount (0.4-3) precise; urgency=low
* Initial version for PVE6
......
......@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 8.0.0)
Package: pve6-usb-automount
Architecture: all
Depends: python3-pyinotify, python3-pyqt5, python3-pyudev
Depends: python3-pyinotify, python3-pyside2.qtcore, python3-pyudev
Conflicts: pve5-usb-automount
Replaces: pve5-usb-automount
Provides: pve6-usb-automount
......
......@@ -14,7 +14,7 @@ import json
from os.path import exists
from pyudev.version import __version_info__
from PyQt5.QtCore import *
from PySide2.QtCore import *
config = configparser.ConfigParser()
config.read('/etc/pve-usb-automount/main.conf')
......@@ -41,7 +41,7 @@ class USBAutomount:
sys.exit(self.app.exec_())
class udevObserver(QObject):
finished = pyqtSignal()
finished = Signal()
keeprunning = True
def process(self):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment